First mods for my Bonny.

Brylcreem

Scooter
Hi all I have attempted my first electrical mods on my 05 Bonny, I bought a Motone ignition relocation bracket left side, but then I found out that I had the shorter cable inside my light bucket which doesn’t reach, so I read the post from Chris in NC about dealing with it, and to my suprise I managed to sort it out, and the connector now lives under my tank next to the coil, hope it’s going to be happy there.
I also purchased the Motone Lucas style plug and play rear light unit with hard wired bullet indicators fitted to it, and it also came with front indicators too.
I removed the existing ones and fitted the new ones in the same place, they went in well but the bolts from which the wires emerge from were to long, when I fitted the headlight back on the bolts were touching the sides of the bucket, so I bought a pack of washers and put 2 on each of them them before refitted to give me more space, job done and and looks great, IMO.
The rear light fitted fine, but they didn’t put the plug in harness in the box, so I rang Squaredeals uk and they were great, they had 2 lengths so I opted for the long one as reviews say they needed to extend the cables as wiring was too short, it was delivered very quickly, so today i fitted it and it looks great, but I had problems connecting the wiring to the harness, most of the colours on the light don’t match what’s on the harness, I managed to get both indicators working, then tried to wire the running light and brake light, black to black has been neutral, there’s a red so connected red, then a blue, but only a green left, turned the ignition on and blew a 10 amp fuse, will need to get some tomorrow to finish the job, but should I switch red to green and blue to red, it’s a bit mad.
I have now borrowed a power tester so I can check for the live wires when I turn the ignition on.
Why did I not think of that earlier, DOH.
Will post the finished mods soon, I hope.
Cheers.
203823203824
 
Last edited:

rbirkey

NBRAdmin
Staff member
Dave, thanks for sharing your experience here. I have done this mod on a few bikes as well... however the kit I purchased was from NewBonneville.com and it is not branded as Motone. It looks exactly the same though.
 

Attachments

Brylcreem

Scooter
Hi, did you have the same problems with the wiring colours for the light, I asked a neighbour who worked for VW motors and he checked it out with a meter, fault was mine Doh, the rear indicator earth wire was black, but the earth on the harness was not the black wires, it was the black with a white stripe, switched them over and all is good now.
I agree that your light looks exactly the same as mine, I ordered amber covers but after seeing yours I think they sent smoked amber ones, but I do like the look of them as they blend in, just hope they are bright enough.

Ps, the longer harness was 20 cm longer than needed, so used some galvanised 2mm diameter garden wire bent it and fixed it under the light fixing bolts, then bent it over the wires, not pretty but worked.
Will post some pics here soon.
 
Last edited:

rbirkey

NBRAdmin
Staff member
I don't remember if these wire colors matched, but I've had many other experiences where they did not. Usually, there is a diagram with the products I get from NewBonneville which helps sort things out. If there isn't, then trial and error usually finds the right combination.
 

Brylcreem

Scooter
7E705CDE-2207-4CA4-8936-EDDC59295F2F.jpegDB7CFFF4-697C-4B1A-A1A2-361EEB6E3012.jpegC6E734B8-4EEC-4C8D-AEA4-D65E829C667D.jpegHere are the photos of the mods done this week.
But will change the smoked amber lenses for amber, not bright enough.
 
Last edited:

Brylcreem

Scooter
I didn’t order smoked lenses on the light kit, but I did like the look of them, they were happy to exchange them for the amber ones that I ordered, I have returned the smoked ones.
I forgot to mention my clocks now have blue led bulbs, after one blew in my speedo.
Updated photos.
.008D696D-EFF6-45E6-9C26-ABBD53099AA4.jpeg
 

Attachments

Last edited:

Brylcreem

Scooter
Dave, thanks for sharing your experience here. I have done this mod on a few bikes as well... however the kit I purchased was from NewBonneville.com and it is not branded as Motone. It looks exactly the same though.
Hi rbirkey, i think the harness is made by Motone as in the picture above, but no branding on the light, I know they got the indicators from the USA as they were waiting for a delivery when I ordered it, may all be from New Bonneville.
 
Top